!更新Kandy应用前请务必保证KandyApp为最新版!

Z-Blog for PHP 自定义列表插件 KandyList 发布及更新

由 吉光片羽 在 4 年前(2014-03-26)

Z-Blog for PHP 自定义列表插件 KandyList 发布及更新猴端程序猿

插件简介

KandyList是一款Z-Blog自定义列表插件,目前仅开发了PHP版本,用于Z-blog for PHP,开发这款插件主要是因为某个单页面主题,接着铆足劲在一天之内做出来了。如果用过Z-Blog早期版本的列表插件(好吧,插件名记不住了,总之就是各种列表调用插件),之前有个超级侧栏什么的(没用过),感觉KandyList的作用就跟他们差不多,如果你用过类似插件,那KandyList也是个不错的选择。

因为某种不被喜好做收费插件的原因,好吧,虽然我很辛苦的做了这个插件(其中的纠葛无人能懂),但还是发布了目前的KandyListS免费版,确切的说是体验版,KandyList还在继续完善中,如果你觉得KandyListS不错,很高兴你能通过购买KandyList高级版的方式来捐助作者吉光片羽,也就是我,谢谢!

插件特点

  • 类可视化编辑,无需任何编码经验。

  • 模块化管理,方便侧栏或独立调用。

  • 模块化数据,无需在每次打开页面的时候都繁复的加载数据,减轻服务器和数据库负担。

  • 数据不延时,每个涉及模块更新的操作如发表编辑文章,评论,新建修改分类等,都会同时更新列表数据。

  • 可自定义标题和摘要长度

  • 可自定义ul列表的li的样式类(class)

  • 可自由选择时间限制,如当天、当月、当年或几天之内的文章、评论和用户

  • 可自由组合选择置顶、有评论或有图片条件的文章

  • 可自由选择按正、倒序以时间、评论、统计次数等或随机的方式排序

  • 可设置模块是否实时更新

  • 可自定义模板或选择默认预设模板

  • 可调用来自文章、页面、分类、评论、标签、用户的数据

  • 可针对子分类进行必要的筛选

  • 可针对用户级别进行必要的筛选

  • 可自由组合多选页面、分类、用户级别、用户、标签

  • 可选择保存模块后返回当前模块

  • 多选项目可搜索关键字进行筛选

  • 模块提交后可及时看到数据预览

  • 相同文件名和htmlid会有重名提醒

  • 提供了若干常用的标签,方便自定义模板

  • 模板标签支持KandyLang语言包

注意事项

  • 收费版需要KandyApp的加持以及KandyLang的协助

  • 收费版的调用标签需包含kandylist-的前缀

  • 使用前请认真阅读管理页面的备注

  • 不熟悉html编码的同学请耐心仔细自定义模板,编码格式错误代码会呈亮红色,错误的编码可能导致页面错乱

插件配置

KandyList不需要配置,安装成功后点击管理按钮会自动转到新建自定义列表界面,如下图(整理自KandyList收费版):

2014年收费版雏形

2018年收费版掠影

收费版自定义列表模块效果

新建的自定义列表会作为各个模块在模块管理中进行维护。

KandyList收费版功能更齐全,同时管理页面采用了KandyUI,在支持HTML5的浏览器下效果更美观。

更新日志

为区分收费及免费版,收费版直接以2.0版进行维护更新,1.X则表示免费版更新

  • 2018-06-22 V2.0
    NEW 收费版发布

  • 2018-06-06 V1.2
    BUG 修复1.5系统模块无法提交修改的问题

  • 2014-04-16 V1.1
    BUG 修复非KandyListS模块无法提交修改的问题

  • 2014-03-26  V1.0
    NEW 免费版发布

下载安装

KandyListS插件为免费插件,KandyList插件为收费插件,如需使用请到博客后台应用中心中搜索KandyList后根据需要选择购买收费版或直接安装免费版,祝您使用愉快!

KandyList仍在开发完善中,敬请期待。

BUG报告

系统版本 请填写所使用Z-Blog系统版本

报错网址 请将报错页面完整地址粘贴至此

报错详情 请将报错详细内容粘贴至此

反馈邮箱 请留下邮箱,修复成功后将第一时间通知您

修改建议 内容请控制在200字以内

验证码

猜你喜欢 Related Posts

各抒己见 Comment

名称

邮箱

主页

访客 访客 3 个月前(06-02) | 回复 【热评】老大,都6月份了还没好吗?这速度无语啊!1 0
吉光片羽 吉光片羽 3 个月前(06-06) | 回复 抱歉未能准时发布收费版,简版已经更新,请继续享用,谢谢!0 0
访客 访客 3 个月前(06-07) | 回复 收费版还有希望吗??0 0
mrszhao mrszhao 1 年前(2017-08-03) | 回复 【热评】作者好,我很想知道通过插件新建的自定义列表是放在了数据库里面吗?我想添加文章缩略图,不知道如何修改生成的文章列表?1 0
吉光片羽 吉光片羽 1 年前(2017-08-24) | 回复 你好,你可能需要修改include.php文件来实现相关需求。0 0
访客 访客 3 个月前(06-11) | 回复 急求高级版吶,望联系我下,联系方式是QQ,和填写的邮箱一样,谢谢!0 0
访客 访客 3 个月前(06-04) | 回复 求更新吶。。求更新吶。。0 0
访客 访客 4 个月前(05-12) | 回复 您好,非常感谢您的优秀插件。请问如何购买高级版,看了展示图片,觉得非常棒,想购买使用下,应用中心没有上线吧?如果可以的话,请联系一下我,谢谢大神!0 0
吉光片羽 吉光片羽 4 个月前(05-13) | 回复 感谢认可与支持,近期正在完善新的主题和插件。KandyList的收费版其实一直可以用,但是始终没有继续完善,所以拖了4年都没发布,既然现在有实际需求,我争取在这个月内完善上线,请保持关注,谢谢!0 0
访客 访客 4 个月前(05-15) | 回复 希望能尽快上线,还希望大神能做个会员中心插件,目前应用中心的貌似都是仿造或者说是偷用别人的,后续升级是个大问题。0 0
访客 访客 4 个月前(05-12) | 回复 上次我曾反馈DIGG插件有一处报1error的问题,也希望能一并解决。0 0
访客 访客 5 个月前(04-24) | 回复 您好,您的插件非常好用,不知道为什么,之前还可以用的,好好的就用不了了,每次提交都是失败的,总是提示非法操作,尝试了也没有与其他插件冲突的情况,想咨询下您该怎么解决呢0 0
吉光片羽 吉光片羽 5 个月前(04-25) | 回复 你好,感谢你的支持!请问是KandyList这个插件出错吗?考虑是升级了1.5.2的系统。如果插件有BUG,有劳在具体的插件发布页面提交BUG报告,以便我及时处理,谢谢!0 0
羊毛多多网 羊毛多多网 4 个月前(05-19) | 回复 感谢作者能提供如此实用的插件,我不懂代码,之前用的应该是1.5.0版本,都可以正常使用,后面可能是我升级了1.5.2的系统还是其他原因,插件正常,每次编辑模块提交就出现非法访问页面,劳烦作者帮忙解惑,再次感谢!如果有收费版本,我可以付费使用,提示错误信息如下:
非法访问
可能的错误原因
如果您是访客,这说明网站程序可能出现了一些错误。请您稍后再试,或联系站长。
如果您是站长,您可以点击【更多信息】来查看Z-Blog官方关于这个错误的说明,也可以到Z-Blog官方论坛,附上错误详细截图与描述寻求帮助。2 0
访客 访客 3 年前(2014-10-08) | 回复 真不错的网站0 0
开一片海 开一片海 4 年前(2014-09-26) | 回复 现在用的就是这个拉,不错噢!!0 0
访客 访客 4 年前(2014-07-14) | 回复 博主有空可以帮我做个手机网页模板吗0 0
访客 访客 4 年前(2014-09-15) | 回复 1 0
访客 访客 4 年前(2014-06-18) | 回复 (0)UNKNOWN : 非法访问
添加时提示这个啊0 0